注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

淡淡人生的博客

分享生活 分享快乐。。。

 
 
 

日志

 
 

【转载】金泉—多头 通达信指标公式源码  

2015-02-23 04:36:11|  分类: 股票基础 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友

金泉—多头    通达信指标公式源码
作者:股市研讨俱乐部

 金泉判官 

金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友
N1:=5;
N2:=10;
N3:=20;
N4:=30;
P:=2;
M:=20;
N:=250;
M1:=55;
W:=21;
P3:=500;
N9:=90;
HR:=HHV(HIGH,M1);
HRY:=LLV(LOW,M1);
HRY11:=HR*HRY;
HRY33:SQRT(HRY11),COLORGREEN,LINETHICK2;
IF(C>HRY33 AND HRY33 >=REF(HRY33 ,1), HRY33 ,DRAWNULL),LINETHICK2,COLORRED;
MA1:EMA(CLOSE,N1);
MA2:EMA(CLOSE,N2);
MA3:EMA(CLOSE,N3),COLOR00FFFF;
MA4:EMA(CLOSE,N4),LINETHICK2;
TJ1:=CROSS(MA1,MA2) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(MA1,MA4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(MA2,MA3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(MA1,MA3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018;
TJ2:=(MAX(MA1,MAX(MA2,MA3))-MIN(MA1,MIN(MA2,MA3)))/
MIN(MA1,MIN(MA2,MA3))*100<=P;
XG:=TJ1 AND TJ2;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
DIFF:= EMA(CLOSE,12) - EMA(CLOSE,26);
DEA :=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
做多:=IF(K>D AND MACD>0 AND V>1,2,0),COLORRED;
做空:=IF(K<D AND MACD<0 AND V>1,-2,0),COLOR00FF00;
强洗:=IF(MACD>0 AND K<D AND V>1,1,0),COLOR0099FF;
弱升:=IF(MACD<0 AND K>D AND V>1,-1,0),COLORFFFF00;
STICKLINE(做多 AND C>=O,C,O,3,1),COLORRED;
STICKLINE(做多 AND C<O,C,O,3,0),COLOR990099;
STICKLINE(做多 AND C<O,C,O,1,0),COLORCC00CC;
STICKLINE(做多 AND C<O,C,O,0.3,0),COLORFF00FF;
STICKLINE(做多 AND C>=O,C,O,3,1),COLOR0000FF;
{STICKLINE(做多 AND C>=O,C,O,1.5,0),COLOR0000DD;
STICKLINE(做多 AND C>=O,C,O,0.4,0),COLOR0000FF;}
STICKLINE(做空 AND C>=O,L,H,0.1,0),COLOR0000FF;
STICKLINE(做空 AND C>=O,C,O,3,1),COLOR00FF00;
{STICKLINE(做空 AND C<O,C,O,3,0),COLOR00FF00;
STICKLINE(做空 AND C<O,C,O,0.3,0),COLOR00FF00;
STICKLINE(做空 AND C<O,C,O,0.3,0),COLOR00FF00;}
STICKLINE(强洗 AND C>=O,L,H,0.1,0),COLOR0000FF;
STICKLINE(强洗 AND C>=O,C,O,3,1),COLORFFFFFF;
STICKLINE(强洗 AND C<O,C,O,3,0),COLOR999999;
STICKLINE(强洗 AND C<O,C,O,1,0),COLORCCCCCC;
STICKLINE(强洗 AND C<O,C,O,0.3,0),COLORFFFFFF;
STICKLINE(弱升 AND C>=O,C,O,3,1),COLOR00FFFF;
STICKLINE(弱升 AND C<O,C,O,3,0),COLOR009999;
STICKLINE(弱升 AND C<O,C,O,0.3,0),COLOR00FFFF;

STICKLINE(FILTER(TJ1,3),C,O,4,0),COLOR0000FF;
DRAWICON(FILTER(XG,3),L*0.985,23);
GET:=ZIG(3,3),COLORYELLOW;
PL5:=ZIG(3,5);
EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
PL10:=ZIG(3,10);
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
PL20:=ZIG(3,20);
EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
PL40:=ZIG(3,40);
走强1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走强2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走强3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
DRAWTEXT(EN1 AND DTJZ5=1,L*0.98,'(A)'),COLORFFFF00;
DRAWTEXT(EX1 AND DTJD5=2,H*1.02,'(B)'),COLORFF00FF;
DRAWTEXT(EN2 AND ZTJZ5=1,L*0.98,'(C)'),COLOR0000FF;
DRAWTEXT(EN2 AND DTJZ10=1,L*0.93,'Ⅰ'),COLORFF00FF;
DRAWTEXT(EX2 AND DTJD10=2,H*1.05,'Ⅱ'),COLORFFFF00;
DRAWTEXT(EN3 AND ZTJZ10=1,L*0.93,'Ⅲ'),COLOR0000FF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.03,'①'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.95,'②'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2)
AND EX2,H*1.03,'③'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,L*0.95,'④'),
LINETHICK3,COLOR00FFFF;
TJ11:=EN2 AND ZTJZ5=1;
TJ22:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2;
TJ33:=EN2 AND DTJZ10=1;
TJ44:=EN3 AND ZTJZ10=1;
TJ55:=EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2;
XG22:=TJ11 OR TJ22 OR TJ33 OR TJ44 OR TJ55;

MM:=C>HRY33 AND HRY33 >=REF(HRY33 ,1);
QQ:=HRY33>=REF(HRY33 ,1);
XG11:=CROSS(C,HRY33)  AND QQ AND MM;
BUY1:=LAST(CLOSE>MA(CLOSE,55),0,5);
BUY2:=EXIST(CLOSE<MA(CLOSE,55),5);
BUY:=CLOSE>MA(CLOSE,55)&&BUY1&&BUY2;
W18:=FILTER(EXIST(XG11 OR BUY,1),5);
STICKLINE(W18,C,(C+O)/2,4,0),COLORFF00FF;
DRAWTEXT(W18,L*0.97,'牛'),COLOR00FFFF;
X1:=REF(C,1)/HHV(H,20)<0.82;
X2:=(MIN(C,O)-L)/(H-L)>0.67;
X3:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)<0.33;
X4:=ABS(C-O)/C<0.01;
DOWN:=O>C;
X5:=COUNT(DOWN,7)>=5;
XG8:=X1 AND X2 AND X3 AND X4 AND X5;
DRAWTEXT(XG8,L*0.98,'螺'),COLOR00FFFF;
AA:=REF(C,1)/REF(O,1)<0.96;
BB:=C/O>1.03;
CC:=C>REF(O,1);
TJ81:=AA AND BB AND CC;
X81:=REF(C,1)/HHV(H,20)<0.82;
DN:=O>C;
X82:=COUNT(DN,7)>=5;
X83:=C=HHV(C,3);
XG81:=TJ81 AND  X81 AND X82;
XG82:=X81 AND X82 AND X83;
XG88:=XG81 OR XG82;
DRAWTEXT(XG88,L*0.96,'反'),COLOR00FFFF;
X01:=REF(C,1)/HHV(H,21)<0.77;
{DOWN1:=O>C;
X02:=COUNT(DOWN1,9)>=6;}
X03:=ABS(C-O)/C<0.008;
X04:=(H-L)/C>0.025;
XG0:=X01  AND X03 AND X04;
DRAWTEXT(XG0,L*0.97,'星'),COLOR00FFFF;
S1:=REF(C,1)/LLV(L,W)>1.30;
S2:=(H-MAX(C,O))/(H-L)>0.60;
S3:=ABS(C-O)/C<0.03;
S4:=(H-O)/C>0.05 AND C<O;
SAL1:=S1 AND S2 AND S3;
SAL2:=S1 AND ABS(C-O)/C>0.05 AND C<O;
SAL3:=S1 AND ABS(C-O)/C<0.001;
SAL4:=S1 AND S4;
SAL5:=(H-MAX(C,O))/(H-L)>0.67 AND C<O AND S3;
SAL:=SAL1 OR SAL2 OR SAL3 OR SAL4 OR SAL5;

LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),4.1,1)/SMA(ABS(CLOSE-LC),4.1,1)*100;
黄买:=FILTER((REF(CLOSE,2)<CLOSE AND RSI<25),7);
黄卖:=FILTER((REF(CLOSE,2)>CLOSE AND RSI>80),7);
红买:=FILTER(CROSS(RSI,11),7);
红卖:=FILTER(CROSS(89,RSI),7);
绿买:=FILTER(CROSS(RSI,20),7);
绿卖:=FILTER(CROSS(80,RSI),7);
SL1:=红卖 AND 绿卖;
SL2:=红卖 AND 绿卖 AND 黄卖;
BU:=红买 AND 绿买;
SS1:=CROSS(MA(C,5),C);
SS2:=(REF(C,1)-C)/REF(C,1)>0.04;
SS3:=O<REF(C,1);
JJ1:=SS1 AND SS2 AND SS3;
SSL:=JJ1 AND S1;
SAL8:=FILTER(SAL OR SSL,5);
DRAWTEXT(SAL8 OR SL1 OR SL2,H*1.02,'卖'),COLOR00FF00;
STICKLINE(SAL8 OR SL1 OR SL2,C,O,1,0),COLORFF0000;
DRAWTEXT(SAL8 AND SL1 AND SL2,H*1.02,'必卖'),COLOR00FF00;
MA20:=MA(CLOSE,20);
AA10:=MA(CLOSE,8);
中期大底:=LLV(LOW,30);
支撑:=HHV(EMA(((((OPEN + LOW) + HIGH) + CLOSE) / 4),5),60);
压力一:=HHV(LOW,20);
中线:=MA(CLOSE,3);
天:=(MA(LOW,15) * 0.985);
人:=(MA(LOW,15) * 0.96);
地:=(((HIGH + LOW) + CLOSE) / 3);
B1:=HHV(地,(4 * 15));
B6:=LLV(地,(4 * 15));
B7:=(B1 - B6);
B8:=(MA(((地 - B6) / B7),2) * 80);
短期底部:=(LLV(HIGH,30) * 0.93);
MA80:=LLV(HIGH,30);
压力二:=(SMA(HIGH,21,2) * 1.035);
下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
RSV8:=SMA(下档线,3,1);
K8:=SMA(RSV8,3,1);
D8:=((3 * RSV8) - (2 * K8));
J12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
K24:=SMA(SMA(J12,3,1),3,1);
D24:=((3 * SMA(J12,3,1)) - (2 * K24));
压力位:=IF(CROSS(D24,D),HIGH,L);
长期底部:=LLV(HIGH,30);
X18:=EMA((((((3 * CLOSE) + HIGH) + LOW) + OPEN) / 6),10);
逃遁:=(SMA(HIGH,21,2) * 1.05);
TJ18:=FILTER(((((LLV(LOW,0) AND ((MA(CLOSE,37) - REF(MA(CLOSE,37),1))
> 0)) AND (LOW <= 短期底部)) AND (WINNER(CLOSE) < 0.05)) AND
((CLOSE / OPEN)> 0.13)),7);

 稳赚

金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友
BF:=MA(CLOSE,20);
上:BF+2*STD(CLOSE,20),NODRAW;
下:BF-2*STD(CLOSE,20),NODRAW;
DRAWBAND(上,RGB(85,20,30),BF,RGB(0,60,5));
DRAWBAND(BF,RGB(0,60,5),下,RGB(0,60,5));
PP:=CROSS(C,MA(C,4));
EE:=STICKLINE(PP AND MA(C,20)>=REF(MA(C,20),1) AND

C>O,H,L,1,0),COLORFF00FF,LINETHICK2;{20日均线走强买点};
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
AA:=MACD>REF(MACD,1) AND REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3)AND

MACD>0;
CT:=MACD>REF(MACD,1) AND REF(MACD,1)>REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF

(MACD,3)<REF(MACD,4)AND MACD>0;
PPO:=MA(C,4)>MA(C,24) AND PP AND MA(C,24)>=REF(MA(C,24),1) ;
VIP:=AA AND PPO OR CT AND PPO;
DRAWICON(VIP=1,LOW*0.95,9),COLORRED;
DRAWKLINE(H,O,L,C);
MA5:MA(CLOSE,5),COLORWHITE;
MA10:MA(CLOSE,10),COLORRED,LINETHICK2;
MA20:MA(CLOSE,20),COLORBLUE;
MA62:=MA(CLOSE,62),POINTDOT,COLORBLUE;
MA133:=MA(CLOSE,133),POINTDOT,COLORGREEN;
{涨幅}
日:((C-REF(C,1))/REF(C,1))*100,COLORRED,NODRAW;
周:((C-REF(C,5))/REF(C,5))*100,COLORLIRED,NODRAW;
月:((C-REF(C,20))/REF(C,20))*100,COLORRED,NODRAW;
季:((C-REF(C,60))/REF(C,60))*100,COLORYELLOW,NODRAW;
STICKLINE(日>=9.95,O,C,2,0),COLORRED,LINETHICK2;
IF(MA10>=MA5,MA10,DRAWNULL),COLORGREEN,LINETHICK2;
IF(MA5<=MA10,MA10,DRAWNULL),COLORGREEN,LINETHICK2;
买线YGB:=EMA(C,2);
卖线YGB:=EMA(SLOPE(C,21)*20+C,42);
指导线:=EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2);
界:=MA(CLOSE,27);
B买:IF(CROSS(指导线,界) OR CROSS(买线YGB,卖线YGB),C,DRAWNULL),COLORMAGENTA,NODRAW;
持仓:IF(买线YGB>=卖线YGB,C,DRAWNULL),COLORRED,NODRAW;
S卖:IF(CROSS(界,指导线) OR CROSS(卖线YGB,买线YGB),C,DRAWNULL),COLORLIGRAY,NODRAW;
空仓:IF(买线YGB<卖线YGB,C,DRAWNULL),COLORGREEN,NODRAW;
N1:=7;
LC:=REF(CLOSE,1);
X:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLORYELLOW,LINETHICK1;
魔鬼:=DRAWLINE(X>=HHV(X,N1),X,X<=LLV(X,N1),X,1),COLOR00FF00;
魔王:=DRAWLINE(X>=HHV(X,N1),X,X<=LLV(X,N1),1,X),COLOR00FF00;
TJ0:=X=魔王;
TJ1:=X=魔鬼;
TJ2:=X<REF(X,1);
TJ3:=X>REF(1,X);
JRS1:=DRAWICON(TJ1 AND TJ2,X,1);
JRS2:=DRAWICON(TJ0 AND TJ3,X,2);
DRAWICON(FILTER(JRS1>0,1),L*0.97,1);
DRAWICON(FILTER(JRS2>0,1),H*1.02,15);
VAR4:=(LOW+HIGH+CLOSE)/3;
操作:=MA(VAR4,5);
拉升:=HHV(操作,13),POINTDOT;
压力:=HHV(操作,60),POINTDOT;
买卖:=LLV(操作,13),POINTDOT;
支撑:=LLV(LOW,60)*1.02,POINTDOT;
顶部:=HHV(HIGH,60)*0.98,POINTDOT,COLORCYAN;


 

 

金泉介入点

金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友

MB1:=EMA(WINNER(C)*100,5),COLORYELLOW;
MB2:EMA(MB1,2),COLORBLUE;
MB3:EMA(MB2,2),COLORBLUE;
MB4:EMA(MB3,2),COLORBLUE;
MB5:EMA(MB4,2),COLORBLUE;
MB6:EMA(MB5,2),COLORBLUE;
MB7:EMA(MB6,2),COLORBLUE;
MB8:EMA(MB7,2),COLORBLUE;
MB9:EMA(MB8,2),COLORBLUE;
MB10:EMA(MB9,2),COLORBLUE;
MB11:EMA(MB10,2),COLORBLUE;
MB12:EMA(MB11,2),COLORBLUE;
MB13:EMA(MB12,2),COLORBLUE;
MB14:EMA(MB13,2),COLORBLUE;
N:=5;
VAR2:MB1;
VAR3:DRAWLINE(VAR2>=HHV(VAR2,N)=1,VAR2,VAR2<=LLV(VAR2,N)=1,VAR2,1);
XG:=REF(VAR2,1)=REF(VAR3,1) AND VAR2>REF(VAR2,1);
STICKLINE(VAR2=VAR3 AND VAR2<MB4,VAR2,VAR2+10,1,0)COLORYELLOW;
STICKLINE(XG,VAR2,VAR2+10,1,0),COLORRED;

金泉K线图

金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友
五:MA(CLOSE,5);
十:MA(CLOSE,10);
三十:MA(CLOSE,30),COLORFF00FF,LINETHICK2;
六十:MA(CLOSE,58),COLOR00FF00,LINETHICK2;
半年:MA(CLOSE,118),COLORFFFF80,LINETHICK2;
年:MA(CLOSE,238),COLORRED,LINETHICK2;
二:MA(CLOSE,500),COLORWHITE,LINETHICK2;
三:MA(CLOSE,750),COLOR8080FF,LINETHICK2;
四:MA(CLOSE,999),COLORYELLOW,LINETHICK2;
MA98:MA(CLOSE,98),COLORGRAY;
MA138:MA(CLOSE,138),COLORGRAY;
MA158:MA(CLOSE,158),COLORGRAY;
MA178:MA(CLOSE,178),COLORGRAY;
MA198:MA(CLOSE,198),COLORGRAY;
MA218:MA(CLOSE,218),COLORGRAY;

IF(十<=REF(十,1),十,DRAWNULL),COLORFF8000,LINETHICK2;
IF(三十<=REF(三十,1),三十,DRAWNULL),COLORFF8000,LINETHICK2;
IF(六十<=REF(六十,1),六十,DRAWNULL),COLORFF8000,LINETHICK2;
IF(半年<=REF(半年,1),半年,DRAWNULL),COLORFF8000,LINETHICK2;
IF(年<=REF(年,1),年,DRAWNULL),COLORFF8000,LINETHICK2;
LLV(LOW,25),COLORYELLOW;

KD不只是传说 ^.^ (副图,原码,贴图,用法)

金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友

RSV2:=(CLOSE-LLV(LOW,168))/(HHV(HIGH,168)-LLV(LOW,168))*100;
K2:=SMA(RSV2,30,1);D2:=SMA(K2,12,1);
HY:=CROSS(K2,D2) AND K2<35;CC:=CROSS(K2,D2);DD:=CROSS(D2,K2);
RSV1:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
K1:=SMA(RSV1,6,1);D1:=SMA(K1,3,1);
RSV3:=(INDEXC-LLV(INDEXL,15))/(HHV(INDEXH,15)-LLV(INDEXL,15))*100;
{以下为显示}
DRAWBAND(K2,RGB(155,50,50),D2,RGB(0,100,50));
DRAWBAND(K1,RGB(255,0,5),D1,RGB(20,100,250));
快K:K1,COLOR009999;快D:D1,COLOR999900;
大盘K:SMA(RSV3,6,1),COLORDD00EE;
DRAWTEXT(HY,K2+5,'有戏'),COLOR00DDDD;

{警戒:STICKLINE(C,90,90,4,0),COLOR00DDDD;
极底:STICKLINE(C,10,10,-1,0),COLOR999900;
强势线:STICKLINE(C,78,78,-1,0),COLOREEEE00;
0,COLOR00FFFF;}

{
六彩神龙(获利、变量)
金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友

变量00:=5;变量01:=30;
A02:=(WINNER((CLOSE *  1.100)) *  100.000);
A03:=(WINNER((CLOSE *  0.9)) *  100.000);
A04:=MA(A03,变量00);
STICKLINE( 1.000,0,A04, 7.450,0),colorred;
获利:MA(A03,变量00),colorred;
A06:=( 100.000 - MA(A02,变量00));
STICKLINE( 1.000, 100.000,MA(A02,变量00), 7.450,0),colorgreen;
套牢: ( 100.000 - MA(A02,变量00)),colorgreen;
A08:=(MA(A02,变量00) - MA(A03,变量00));
STICKLINE( 1.000,A04,MA(A02,变量00), 7.450,0),coloryellow;
浮动: (MA(A02,变量00) - MA(A03,变量00)),coloryellow;
A0A:=(((((HHV(A04, 15.000) - A03) / A03) *  100.000) > 变量01) and (HHV(A04, 15.000) >  50.000));

STICKLINE(A0A,(0 -  2.000), 2.000, 10.000,0);
STICKLINE(NOT(A0A),(0 -  2.000), 2.000, 10.000,0),colorblue;

操盘密码

金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友
{公称名称: 操盘密码}
CP1:HHV(HIGH,60),COLOR00FFFF;
CP2:HHV(CLOSE,1),COLORFFFFFF;
底部支撑:LLV(LOW,60),COLOR6666FF;
(EMA(CLOSE,240) * 0.75),COLOR0000FF,LINETHICK3;
铁底:(EMA(CLOSE,240) * 0.75),COLOR00FFFF;
VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,30);
『强势』:DRAWTEXT((VAR1 > VAR2),VAR2,'↑'),COLOR0000FF;
『弱势』:DRAWTEXT((VAR1 <= VAR2),VAR2,'↓'),COLOR00FF00;
VAR3:=MA(CLOSE,20);
VAR4:=MA(CLOSE,60);
VAR5:=CROSS(VAR3,VAR4);
DRAWICON(VAR5,(HIGH * 1.04),2);
DRAWTEXT(VAR5,(HIGH * 1.06),'卖出'),COLORFFFFFF;
VAR6:=CROSS(VAR1,VAR2);
DRAWICON((VAR6 AND (CLOSE < 铁底)),(LOW - (LOW * 0.04)),1);
DRAWTEXT((VAR6 AND (CLOSE < 铁底)),(LOW - (LOW * 0.05)),'←中底买'),COLOR0000FF;
VAR7:=(((CLOSE - OPEN) / REF(CLOSE,1)) > 0.08);
DRAWTEXT(FILTER(VAR7,1),(LOW * 0.99),'追'),COLOR00FFFF;
DRAWTEXT(CROSS(底部支撑,铁底),(LOW - (LOW * 0.02)),'小底'),COLOR00FFCC;
DRAWTEXT(((MONTH = 7) AND (DAY = 28)),(底部支撑 - (底部支撑 * 0.02)),'仿《操盘密码3.0》'),COLORFFFFFF;

抄底收银

金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友

STICKLINE(C>0,0,90,100,0),COLOR373829;
VAR1:=(HHV(HIGH,21)-C)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
VAR2:=(C-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
VAR3:=SMA(VAR2,13,8);
高位:90;
低位:0;
多方: SMA(VAR3,13,8),COLORRED,LINETHICK3;
空方: SMA(VAR1,21,8),COLORGREEN,LINETHICK3;
中轴:45;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
MRD:=CROSS(FF,MA15);
DRAWTEXT(MRD ,25 ,'买' ),COLORFFFFFF;
买: IF(MRD ,10 ,0),COLORFFFFFF;
MCD:=CROSS(85,RSI);
卖: IF(MCD ,80 ,90),COLOR00FF00;
DRAWTEXT(MCD,75,'卖'),COLOR00FF00;

 


波段绝品

金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友

VAR1B:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2B:=SMA(VAR1B,9,1)+100;
VAR3B:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4B:=SMA(VAR3B,3,1);
VAR5B:=SMA(VAR4B,3,1)+100;
VAR6B:=VAR5B-VAR2B;
趋势1: IF(VAR6B>45,VAR6B-45,0),COLOR00FFFF,LINETHICK2;
VAR2Q:=REF(LOW,1);
VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/999*VAR7Q;
火焰山:=IF(VAR8Q>100,100,VAR8Q);
STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0 ,火焰山*1.2,3.5,0 ),COLOR4444FF;
STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0 ,火焰山*1.2,2.5,0 ),COLOR5555FF;
STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0 ,火焰山*1.2,1.5,0 ),COLOR7777FF;
STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0 ,火焰山*1.2,0.5,0 ),COLOR9999FF;
STICKLINE(REF(趋势1,1)< 趋势1, 趋势1,REF(趋势1,1),3.5,0),COLOR000033;
STICKLINE(REF(趋势1,1)< 趋势1, 趋势1,REF(趋势1,1),2.8,0),COLOR000055;
STICKLINE(REF(趋势1,1)< 趋势1, 趋势1,REF(趋势1,1),2.0,0),COLOR000077;
STICKLINE(REF(趋势1,1)< 趋势1, 趋势1,REF(趋势1,1),1.2,0),COLOR000099;
STICKLINE(REF(趋势1,1)< 趋势1, 趋势1,REF(趋势1,1),0.4,0),COLOR0000DD;
STICKLINE(REF(趋势1,1)> 趋势1, 趋势1,REF(趋势1,1),3.5,0),COLOR003300;
STICKLINE(REF(趋势1,1)> 趋势1, 趋势1,REF(趋势1,1),2.8,0),COLOR005500;
STICKLINE(REF(趋势1,1)> 趋势1, 趋势1,REF(趋势1,1),2.0,0),COLOR007700;
STICKLINE(REF(趋势1,1)> 趋势1, 趋势1,REF(趋势1,1),1.2,0),COLOR009900;
STICKLINE(REF(趋势1,1)> 趋势1, 趋势1,REF(趋势1,1),0.4,0),COLOR00DD00;
逃顶:=CROSS(82,RSI);
STICKLINE( 逃顶,逃顶,10,3.5,0),COLORFF5500;
STICKLINE( 逃顶,逃顶,15,2.5,0),COLORFF8800;
STICKLINE( 逃顶,逃顶,20,1.5,0),COLORFFAA00;
STICKLINE( 逃顶,逃顶,25,0.5,0),COLORFFCC00;
STICKLINE( 逃顶,逃顶,30,0.1,0),COLORFFFF00;
D1:=(C+L+H)/3;
D2:=EMA(D1,6);
D3:=EMA(D2,5);
BBUY:=CROSS(D2,D3);
强弱线:50,COLORGREEN,POINTDOT;
DRAWICON(BBUY,20,1);
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARR1),10,15);
DRAWTEXT(CROSS(82,VARR1),35,'逃'),COLORYELLOW;

 

强拉升

金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友
Y1:=LLV(L,17);
Y2:=SMA(ABS(L-REF(L,1)),17,1);
Y3:=SMA(MAX(L-REF(L,1),0),17,2);
Q:=-(EMA(IF(L<=Y1,Y2/Y3,-3),1));
STICKLINE(CROSS(Q,0),15,0,4,0), , COLORYELLOW;
强拉升: IF(CROSS(Q,0),1,0),COLORYELLOW;
Q1:= (CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100, , COLOR00FF00,LINETHICK2;
STICKLINE(CROSS(Q1,-24),20,0,4,0), , COLORMAGENTA;
加强拉升: IF(CROSS(Q1,-24),1,0),COLORMAGENTA;
VAR22:=EXPMA(EXPMA(EXPMA((2*CLOSE+HIGH+LOW)/4,4),4),4);
天:=( MA((VAR22-REF(VAR22,1))/REF(VAR22,1)*100,2));
地:=( MA((VAR22-REF(VAR22,1))/REF(VAR22,1)*100,1));
STICKLINE(地>天 AND 地<0,10,0,1,0),COLORRED;
开始拉升:STICKLINE(地>天 AND 地<0,10,0,1,0)=1,COLORRED;

牛牛的牛公式
金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友


PJJ:=DMA((H + L + C * 2) / 4,0.9);
JJ:=REF(EMA(PJJ,3),1);
QJJ:=VOL / ((H - L) * 2 - ABS(C - O));
XVL:=IF(C > O,QJJ * (H - L),IF(C < O,QJJ * (H - O + (C - L)),VOL / 2))
+ IF(C > O,0 - QJJ * (H - C + (O - L)),IF(C < O,0 - QJJ * (H - L),0 - VOL / 2));
HSL:=XVL / 20 / 1.15;
攻击流量:=HSL * 0.55 + REF(HSL,1) * 0.33 + REF(HSL,2) * 0.22;
GJJ:=EMA(攻击流量,2);
DIFF:=(EMA(GJJ,12)-EMA(GJJ,26)),COLORGREEN;
DEA:=MA(DIFF,2),COLORYELLOW;
VA2:=LLV(LOW,33);
VA3:=HHV(HIGH,21);
VA4:=EMA((CLOSE-VA2)/(VA3-VA2)*100,10)*-1+100;
趋势:=100-EMA(0.191*REF(VA4,1)+0.809*VA4,1);
趋势线:=100-EMA(0.191*REF(VA4,1)+0.809*VA4,1);
STICKLINE(DIFF>DEA AND 趋势线>REF(趋势线,1),
HHV(H,5)*1.05,LLV(L,5)*0.95,4,0),COLOR781836;
DRAWKLINE(H,O,L,C);   
V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2:=(1-7/100)*(DMA(CLOSE,V1));
V3:=(1+7/100)*(DMA(CLOSE,V1));
V5:=MA((LOW+HIGH+CLOSE)/3,5);
支撑:REFDATE(V2,DATE),POINTDOT,LINETHICK3,COLORCC66FF;
阻力:REFDATE(V3,DATE),POINTDOT,LINETHICK3,COLORGREEN;
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
STICKLINE(VAR19,L,L*0.98,3,0),COLORYELLOW;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,H*1.01,H,3,0),COLOR00FF00{98FD};
MA3:MA(C,3);
MA5:MA(C,5),COLORWHITE;
MA10:=MA(C,10),NODRAW;
MA30:MA(C,34),NODRAW;
五日乖离率:=(C-MA5)/MA5*100;
BB5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
IF(BB5>30 AND MA5>REF(MA5,1), MA5,DRAWNULL),LINETHICK1,COLORRED;
BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
IF(BB5<0 AND MA5<REF(MA5,1), MA5,DRAWNULL),LINETHICK1,COLORGREEN;
DD5:=MA5<REF(MA5,1);
IF(DD5,MA5,DRAWNULL),COLOR00FF00;
X0:=(3*C+L+O+H)/6;
多空线: (20*X0+19*REF(X0,1)+18*REF(X0,2)+17*REF(X0,3)+16*REF(X0,4)+15*REF(X0,5)+14*REF(X0,6)
+13*REF(X0,7)+12*REF(X0,8)+11*REF(X0,9)+10*REF(X0,10)+9*REF(X0,11)+8*REF(X0,12)
+7*REF(X0,13)+6*REF(X0,14)+5*REF(X0,15)+4*REF(X0,16)+3*REF(X0,17)+2*REF(X0,18)+
REF(X0,20))/210,COLORFF00FF,LINETHICK1;
{用法:黄托底买进,绿压顶买出。}
DD:=多空线<REF(多空线,1);
IF(DD,多空线,DRAWNULL),COLORBLUE,LINETHICK2;
A:=(MA5>多空线);
IF(A,多空线,DRAWNULL),COLORYELLOW,POINTDOT;
A1:=(MA5<多空线);
IF(A1,多空线,DRAWNULL),COLORWHITE;
A2:=3*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5)-2*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5);
A4:=(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34))*100;
A5:=EMA(CLOSE,12)-EMA(CLOSE,26);
A6:=EMA(A5,9);
A7:=(A5<-0.1 AND A5>A6);
财神:IF(A7,LLV(L,21),DRAWNULL)COLORRED,CIRCLEDOT;
CYS:=(EMA((CLOSE-V2)/V2,1)*100);
AA0:=CYS;
MIDD:=MA(CYS,20);
CC0:=MIDD+0.85*STD(CYS,10);
TM6:=AA0>CC0;
IF(TM6,MA5,DRAWNULL),COLORRED,LINETHICK1;
A0:=(L+H+C*2)/4;
工作:=EMA(A0,14)COLORYELLOW,LINETHICK1;
度假:=EMA(A0,25)COLORYELLOW,LINETHICK1;
A1X:=(工作-REF(工作,1))/REF(工作,1)*100;
A2X:=(度假-REF(度假,1))/REF(度假,1)*100;
G:=BARSLAST(CROSS(A1X,0));
{KDJ}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
金叉:=CROSS(J,D);
死叉:=CROSS(D,J);
买1:=(VAR14 OR VAR15) AND VAR11;
买2:=(VAR14 OR VAR15) AND VAR4;
买3:=(VAR14 OR VAR15) AND VAR2;
买4:=(VAR2 AND VAR11) OR (VAR4 AND VAR11);
买5:=(金叉 AND VAR4) OR (金叉 AND VAR2) OR (金叉 AND VAR11);
{涨停}
STICKLINE(CLOSE>REF(CLOSE,1)*1.0985 AND CLOSE=HIGH,CLOSE,OPEN,4,-1),COLOR00FFFF;
{跌停}
STICKLINE(CLOSE<REF(CLOSE,1)*0.9015 AND CLOSE=LOW,CLOSE,OPEN,4,-1),COLORGREEN;
{蓝}
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3,0),COLORFF7700;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.2,0),COLORFF9900;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.5,0),COLORFFBB00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,0.5,0),COLORCYAN;
{红}
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.5,0),COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.5,0),COLORCC66FF;
{绿}
STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,3,0),COLOR009900;
STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,2.2,0),COLOR00BB00;
STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,1.5,0),COLOR00DD00;
STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,0.5,0),COLOR00FF00;
{灰} STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,3,0),COLOR999999;
STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,2.2,0),COLORBBBBBB;
STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,1.5,0),COLORDDDDDD;
STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,0.5,0),COLORFFFFFF;
STICKLINE(金叉,OPEN,CLOSE,0.5,0),COLORYELLOW;
STICKLINE(死叉,OPEN,CLOSE,0.5,0),COLOR000099;
DRAWICON(VAR16,LOW-0.02,7);DRAWICON(买1 OR 买2 OR 买3 OR 买4 OR 买5,LOW-0.01,1);
DRAWICON(死叉 OR VAR12 OR CROSS(40,VAR9),HIGH+0.01,2);
STICKLINE(CROSS(A1X,0),C,O,1,0)COLORFFFFFF;
STICKLINE(CROSS(0,A1X),C,O,1,0)COLORGREEN;
AX:=XMA(C,3);
DRAWICON(H/AX>1.05,H*1.01,2);
N1:=6;
AA:=REF(H,N1)=HHV(H,2*N1+1);  AA1:=REF(L,N1)=LLV(L,2*N1+1);
QY:=BACKSET(AA,N1+1);  QY1:=BACKSET(AA1,N1+1);
CC:=FILTER(QY,N1) AND H=HHV(H,N1+1);  CC1:=FILTER(QY1,N1) AND L=LLV(L,N1+1);
DDD:=BARSLAST(CC);  DD1:=BARSLAST(CC1);
GDTS:=IF(CC,CURRBARSCOUNT,0);  DDTS:=IF(CC1,CURRBARSCOUNT,0);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);  DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
GDCS1:=CONST(DINGBUTS);  DDCS1:=CONST(DDTS1);
GDCS13:=CONST(REF(HIGH,GDCS1-1));  DDCS13:=CONST(REF(L,DDCS1-1));
DINGBUTS1:=REF(DINGBUTS,DDD+1);  DDTS2:=REF(DDTS1,DD1+1);
GDCS2:=CONST(DINGBUTS1);  DDCS2:=CONST(DDTS2);
GDCS23:=CONST(REF(HIGH,DINGBUTS1-1));  DDCS23:=CONST(REF(L,DDTS2-1));
XG1:=BACKSET(ISLASTBAR,GDCS1);  XD1:=BACKSET(ISLASTBAR,DDCS1);
XG2:=BACKSET(ISLASTBAR,DINGBUTS1);  XD2:=BACKSET(ISLASTBAR,DDTS2);
XDD:=IF(DDCS13<=DDCS23,XD1,XD2);
M:=INTPART(3*N1/5);
AAA:=REF(H,M)=HHV(H,2*M+1);
QYY:=BACKSET(AAA,M+1);
CCC:=FILTER(QYY,M) AND H=HHV(H,M+1);
DDDD:=BARSLAST(CCC),NODRAW;
GDTSS:=IF(CCC,CURRBARSCOUNT,0);
DINGBUTSS:=IF(DDDD,REF(GDTSS,DDDD),GDTSS);
GDCS11:=CONST(DINGBUTSS);
DINGBUTS11:=REF(DINGBUTSS,DDDD+1);
GDCS22:=CONST(DINGBUTS11);
AA11:=REF(L,M)=LLV(L,2*M+1);
QY11:=BACKSET(AA11,M+1);
CC11:=FILTER(QY11,M) AND L=LLV(L,M+1);
DD11:=BARSLAST(CC11);
DDTSS:=IF(CC11,CURRBARSCOUNT,0);
DDTS11:=IF(DD11,REF(DDTSS,DD11),DDTSS);
DDCS11:=CONST(DDTS11);
DDTS22:=REF(DDTS11,DD11+1);
DDCS22:=CONST(DDTS22);
HH1:= REF(H,GDCS1-1),NODRAW;
HH2:= REF(H,GDCS2-1),NODRAW;
HH11:= REF(H,GDCS11-1),NODRAW;
HH22:= REF(H,GDCS22-1),NODRAW;
GHH1:=MAX(MAX(REF(H,GDCS1-1),REF(H,GDCS2-1)),MAX(REF(H,GDCS11-1),REF(H,GDCS22-1))),NODRAW;
DLL1:=MIN(MIN(REF(L,DDCS1-1),REF(L,DDCS2-1)),MIN(REF(L,DDCS11-1),REF(L,DDCS22-1))),NODRAW;
GHH:=MAX(GHH1,HHV(H,10));
DLL:=MIN(DLL1,LLV(L,10));
DX1:=(REF(H,GDCS1-1)-REF(H,GDCS2-1))/(GDCS2-GDCS1),NODRAW;
DX2:=(REF(H,GDCS11-1)-REF(H,GDCS22-1))/(GDCS22-GDCS11),NODRAW;
GGAA:=DX1>0 AND (REF(H,(GDCS1-1))+DX1*GDCS1)>GHH*1.05,NODRAW;
GGAB:=DX1<0 AND (REF(H,(GDCS1-1))+DX1*GDCS1)<DLL*0.95,NODRAW;
DDX1:=IF(GGAA OR GGAB,0,1),NODRAW;
GGBA:=DX2>0 AND (REF(H,(GDCS11-1))+DX2*GDCS11)>GHH*1.05,NODRAW;
GGBB:=DX2<0 AND (REF(H,(GDCS11-1))+DX2*GDCS11)<DLL*0.95,NODRAW;
DDDX1:=IF(GGBA OR GGBB,0,1),NODRAW;
LX1:=(REF(L,DDCS1-1)-REF(L,DDCS2-1))/(DDCS2-DDCS1),NODRAW;
LX2:=(REF(L,DDCS11-1)-REF(L,DDCS22-1))/(DDCS22-DDCS11),NODRAW;
DDAA:=LX1<0 AND (REF(L,(DDCS1-1))+LX1*DDCS1)<DLL*0.95,NODRAW;
DDAB:=LX1>0 AND (REF(L,(DDCS1-1))+LX1*DDCS1)>GHH*1.05,NODRAW;
LLX1:=IF(DDAA OR DDAB,0,1);
DDBA:=LX2<0 AND (REF(L,(DDCS11-1))+LX2*DDCS11)<DLL*0.95,NODRAW;
DDBB:=LX2>0 AND (REF(L,(DDCS11-1))+LX2*DDCS11)>GHH*1.05,NODRAW;
LLLX1:=IF(DDBA OR DDBB,0,1),NODRAW;
长压力:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,DDX1),COLORYELLOW,LINETHICK2;
长支撑:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,LLX1),COLORYELLOW,LINETHICK2;
长中轨:(长压力+长支撑)/2,POINTDOT,COLORYELLOW,LINETHICK4;
短压力:DRAWLINE(CURRBARSCOUNT=GDCS22 ,H,CURRBARSCOUNT=GDCS11,H,DDDX1),COLORLIBLUE,LINETHICK1;
短支撑:DRAWLINE(CURRBARSCOUNT=DDCS22 ,L,CURRBARSCOUNT=DDCS11,L,LLLX1),COLORLIBLUE,LINETHICK1;
短中轨:(短压力+短支撑)/2,POINTDOT,COLORLIBLUE,LINETHICK4;

 


红帆黑牛主图

金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3.1,0),COLOR000055;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),2.7,0),COLOR000077;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),2.1,0),COLOR000099;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),1.5,0),COLOR0000BB;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),0.9,0),COLOR0000DD;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),0.3,0),COLOR0000FF;
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14
OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),3.1,0),COLOR00AAFF;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14
OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),2.7,0),COLOR00DDFF;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14
OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),2.1,0),COLOR00EEFF;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14
OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),1.5,0),COLOR22FFFF;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14
OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),0.9,0),COLOR99FFFF;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14
OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),0.3,0),COLORFFFFFF;
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3,0),COLORMAGENTA;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR008800;
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=3*K24-2*D24;
A1:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));
DRAWTEXT(REF(C,A1+1)>C AND REF("MACD.DIF",A1+1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA")>0,L-0.02,'★M'),COLOR00FFFF;{MACD底背离}
A2:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));
DRAWTEXT(REF(C,A2+1)>C AND REF("KDJ.K",A2+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D"),L-0.10,'◎K'),COLORFF00FF;{KDJ底背离}
A3:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));
DRAWTEXT(REF(C,A3+1)>C AND REF("RSI.RSI1",A3+1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2")>0,L-0.18,'◆R'),COLOR0000FF;{RSI底背离};
C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));
DRAWTEXT(REF(C,C1+1)<C AND REF("MACD.DIF",C1+1)>"MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF")>0,H+0.16,'★M'),COLOR00FF00;{MACD顶背离};
C2:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));
DRAWTEXT(REF(C,C2+1)<C AND REF("KDJ.K",C2+1)>"KDJ.K" AND CROSS("KDJ.D","KDJ.K")>0,H+0.08,'◎K'),COLORFFFFCC;{KDJ顶背离}
C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));
DRAWTEXT(REF(C,C3+1)<C AND REF("RSI.RSI1",C3+1)>"RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1")>0,H+0.04,'◆R'),COLORFF9900;{RSI顶背离};
重心:=(C+0.618*REF(C,1)+0.382*REF(C,1)+0.236*REF(C,3)+0.146*REF(C,4))/2.382;
【操盘线】:EMA(((SLOPE(C,22)*20)+C),55),COLORYELLOW,LINETHICK4;
【黄金线】:IF(重心>=【操盘线】,【操盘线】,DRAWNULL),COLORRED,LINETHICK2;
【空仓线】:IF(重心<【操盘线】,【操盘线】,DRAWNULL),COLORCYAN,LINETHICK2;
DRAWTEXT(ISLASTBAR,【操盘线】,'【操盘线】'),COLORRED;
{引:EMA(CLOSE,2),LINETHICK1,COLORMAGENTA;
探:MA(CLOSE,5),LINETHICK1;};
变:EMA(CLOSE,5),LINETHICK1,COLORYELLOW;
金:IF(变>REF(变,1),变,DRAWNULL),COLORRED,LINETHICK1;
空:IF(变<REF(变,1),变,DRAWNULL),COLORGREEN,LINETHICK1;
DRAWTEXT(ISLASTBAR,变,'【雷达线】'),COLORRED;
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(O,1)),1,0);
STICKLINE(涨停,O,C,1,0),COLORYELLOW;
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF<-9.9,O,C,1,0),COLORBLUE;
PH:=TROUGHBARS(2,5,1);
LL:=HHV(H,PH);
TJ1:=LL=HIGH AND LL<REF(LL,1);{//=1}
TS:=SUMBARS(TJ1,2);
TJ:=PEAKBARS(2,5,1)=1 AND TS>=PH;
PL:=BARSLAST(TJ);
支撑:IF(BARSLAST(TJ1),
REF(LOW,BARSLAST(TJ1)),DRAWNULL),COLOREA91B5;
压力:IF(BARSLAST(TJ),REF(HIGH,PL),DRAWNULL),COLORYELLOW;
TJ_2:=LOW>REF(REF(LOW,TS),PL);
DRAWTEXT(ISLASTBAR,压力,'压力'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,支撑,'支撑'),COLOREA91B5;

 

 

动力KDJ(副图、源码、贴图)

 金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友

该指标特色之处:
1、红色部分代表主力买入,黄色代表主力高抛低吸,通达信显示为绿色,蓝色代表主力卖出
2、J值在顶部,谨慎,重点关注,同时结合我前期发的导弹攻击,综合参考,把握更加精准!
3、该指标优点在于很多主力借助DDE骗散户,而且对于妖股特别实用
布林极限:=100*(C-MA(C,20))/STD(C,20);
布林K值:=EMA(布林极限,10);
VAR2:=EMA(布林极限,5);
VAR3:=EMA(布林K值,5);
STICKLINE(VAR2>=VAR3,101,103,3,0),COLOR00FFFF;
STICKLINE(布林极限>=0,99,101,3,0),COLOR0000FF;
VAR1K:=(L+H+2*C)/4;
VAR2K:=REF(VAR1K,1);
VAR3K:=SMA(VAR1K-VAR2K,6,1)/SMA(ABS(VAR1K-VAR2K),2,1)*100;
MMS:=VAR3K+50;
MMM:=EMA(MMS,8);
STICKLINE(MMS>=100,105,107,6,0),COLORFFFFFF;
STICKLINE(MMS<0,-12,-14,2,0),COLORFFFFFF;
MAV:=(C*2+H+L)/4;
SK:=EMA(MAV,1)-EMA(MAV,40);
SD:=EMA(SK,5);
B:=(SK-SD)*50;
A:=(HHV(H,5)-C)/(HHV(H,5)-LLV(L,5))*10;
A1:=(3*A-2*SMA(A,3,1));
短线阻力:=IF(A1>50,50,IF(A1<-5,-5,A1));
短线能量:=IF(B<-20,-20,IF(B>50,50,B));
STICKLINE(短线能量>=短线阻力,0,短线能量+10,2,0),COLOR0000FF;
STICKLINE(短线能量>=短线阻力 AND 短线能量-REF(短线能量,1)<0,0,短线能量/2+10,2,0),COLOR00FF00;
STICKLINE(短线能量<短线阻力,0,短线能量+10,2,0),COLORFF0000;
BIAS1W:=(C-MA(C,6))/MA(C,6)*100;{BIAS}
BIAS2W:=(C-MA(C,12))/MA(C,12)*100;
BIAS3W:=(C-MA(C,24))/MA(C,24)*100;
MM:=(BIAS1W+2*BIAS2W+3*BIAS3W)/6;
MN:=MA(MM,3);
STICKLINE(MN<-12,-10,-12,2,0),COLOR00FF00;
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1),COLORFF0000;
D:SMA(K,3,1),COLORFF0000;
J:3*K-2*D,COLOR00FF00;
DRAWICON(CROSS(J,D) AND D<=20,18,12);
IF(J<K,J,DRAWNULL),COLORFFFF00;
动力KDJ:IF(J>K,J,DRAWNULL),COLOR00FFFF;
IF(J>K AND J<REF(J,1),J,DRAWNULL),COLOR00FF00;
IF(J>K,D,DRAWNULL),COLOR00FF00;

潜龙出击-通达信指标公式源码

金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友



{N=26}
STICKLINE(50,50,-50,10,0),COLORFFB900,LINETHICK7;
RSVP:=(C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100-50;
KV:=SMA(RSVP,3,1);
DV:=SMA(KV,3,1);
JV:=3*KV-2*DV;
ZDZK1:=EMA(JV,6);
ZDZK2:=REF(ZDZK1,1);
XW1:=IF(O<=REF(O,1),0,MAX((H-O),(O-REF(O,1))));
XW2:=IF(O>=REF(O,1),0,MAX((O-L),(O-REF(O,1))));
XW3:=SUM(XW1,21);
XW4:=SUM(XW2,21);
XW5:=IF(XW3>XW4,(XW3-XW4)/XW3,IF(XW3=XW4,0,(XW3-XW4)/XW4));
{14天强弱}
RS:=SMA(MAX(C-REF(C,1),0),14,1)/SMA(ABS(C-REF(C,1)),14,1)*100;
ZD:= EMA(EMA(EMA(RS,7),3),3);
ZD1:=(ZD-REF(ZD,1))/REF(ZD,1)*15;
STICKLINE(ZD1>=0,0,ZD1*50,2,0),COLOR0000BE;
STICKLINE(ZD1<=0,0,ZD1*50,2,0),COLORGREEN;
Y1:=AMOUNT/V/100;
Y2:=(3*H+L+O+2*C)/7;
Y3:=100*(WINNER(1.1*C)-WINNER(0.9*C));
Y4:=SUM(AMOUNT,13)/Y1/100;
Y5:= DMA(Y2,V/Y4);
Y6:=(C-Y5)/Y5*100;
Y7:=(Y3<10) AND (Y6<=-10);
Y8:=SMA(MAX(C-REF(C,1.5),0),6,1)/SMA(ABS(C-REF(C,1.5)),1,1)*100;
重亏:STICKLINE(Y6<=-10 AND ZD1<0,ZD1*55,ZD1*45,2,0),COLORFF89B2;
全亏:STICKLINE(Y6<=-16 AND ZD1<0,ZD1*60,ZD1*55,2,1),COLORBLUE;
超跌:STICKLINE(Y7 AND ZD1<0,ZD1*65,ZD1*60,2,0),COLORFFFFFF;
{备战区1}
ZDD1:=(HHV(H,21)-C)/(HHV(H,21)-LLV(L,21))*100-10;
ZDD2:=(C-LLV(L,21))/(HHV(H,21)-LLV(L,21))*100;
ZDD3:=SMA(ZDD2,13,8);
ZDD4:=CEILING(SMA(ZDD3,13,8));
ZDD5:=SMA(ZDD1,21,8);
XH1:=SMA(MAX(C-REF(C,2),0),7,1)/SMA(ABS(C-REF(C,2)),7,1)*100;
XH2:=ZDD4-ZDD5<-65 AND XH1<12;
备战区:=XH2;
{备战区2}
XX1:=MA(LOW,2)*0.96;
XX2:=MA(LOW,26)*0.85;
XX3:= REF(XX1,1)<XX2 AND REF(XX1,1)<XX1 AND REF(XX1,1)<REF(XX1,2);{30}
备战区2:=XX3;
C0:=REF(C,2)*0.865;
C1:=REF(C,13)*0.772;
DSY:=100*VOL/CAPITAL;
备战区3:=(C-MIN(C0,C1))/C<0.1 AND SUM(DSY,5)/5<1.8;
{STICKLINE((C-MIN(C0,C1))/C<0.1 AND SUM(DSY,5)/5<1.8,0,ZD1*25,1,0),COLOR006EFF;
DRAWICON((C-MIN(C0,C1))/C<0.1 AND SUM(DSY,5)/5<1.8,0,1);}
{备战区4}
WW1:= SUM( MA(C,10),9)/10.110;
WW2:=CROSS(C,WW1);
备战区4:=WW2;
STICKLINE((备战区1 OR 备战区2 OR 备战区3 OR 备战区4),0,ZD1*25,1,0),COLOR006EFF;
DRAWICON(备战区1 OR 备战区2 OR 备战区3 OR 备战区4,0,1);
{买1}
VW1:=DMA(EMA(C,12),SUM(V,5)/3/CAPITAL);
VW2:=REF(H,10)/C>1.35;
VW3:=(COST(20)-C)/C>0.15;
VW4:=H>L*1.051;
VW5:=VW4 AND COUNT(VW4,5)>1;
VW6:=(((C-VW1)/VW1*100<-30) OR VW2) AND VW3 AND VW5;
{STICKLINE(VW6,0,ZD1*-40,1,0),COLOR0000FF;}
DRAWICON(VW6,ZD1*-40,4);
{买2}
XL1:=MA(LOW,2)*0.96;
XL2:=MA(LOW,26)*0.85;
XL3:=REF(XL1,1)<XL2 AND REF(XL1,1)<XL1 AND REF(XL1,1)<REF(XL1,2);
STICKLINE(XL3 OR VW6,0,15,1,0),COLORF8B7F0;
DRAWTEXT(XL3 OR VW6,15,'←买'),COLORF8B7F0;
{井喷}
JJP1:=REF(INDEXC,1);
JJP2:=FILTER((INDEXC-JJP1)/JJP1>0.03 AND ZDZK1>=ZDZK2,7);
STICKLINE(JJP2,0,-15,4,0),COLORFF00FF;
DRAWTEXT(JJP2,-15,'←买'),COLORFF00FF;
X1:=EMA(HHV(H,500),21);
X2:=EMA(HHV(H,250),21);
X3:=EMA(HHV(H,90),21);
X4:=EMA(LLV(L,500),21);
X5:=EMA(LLV(L,250),21);
X6:=EMA(LLV(L,90),21);
X7:=EMA((X1*0.558+X2*0.558+X3*0.558+X4*0.96+X5*0.96+X6*0.96)/6,21);
X8:=EMA((X1*0.55 +X2*0.55+ X3*0.65+ X4*1.25+X5*1.23+X6*1.2 )/6,21);
X9:=EMA((X1*0.68+ X2*0.68+ X3*0.68+ X4*1.3 +X5*1.3+ X6*1.3 )/6,21);
VARA:=EMA((X7*3+X8*2+X9)/6*1.738,21);
VARB:=REF(LOW,1);
VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
VARD:=EMA(IF(C*1.35<=VARA,VARC*10,VARC/10),3);
VARE:=LLV(L,30);
VARF:=HHV(VARD,30);
VAR10:=IF(MA(C,58),1,0);
VAR11:=EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10;
MID:=REF(H+L,1)/2;

出击:=IF(CR<60 AND VAR11>10,35,0),COLORGREEN;
攻击:=IF (VAR11>20,30,0),COLORYELLOW;
{加仓}
XC1:=(MA(C,80)-MA(C,13)/3);
XC2:= MA((C-XC1)/XC1,1);
XC3:=EMA(XC2,12)*0.7;
XC4:=EMA(XC2,3);
XC5:=IF(LLV(XC4-XC3,12)>0,0,-10);
XC6:=EMA(C,12)-EMA(C,26);
XC7:=EMA(XC6,9);
XC8:=2*(XC6-XC7);
加仓:=IF(XC5<0 AND CROSS(XC8,0),50,0),LINETHICK1,COLORBLUE;
出击加仓:IF((出击=35 OR 攻击=30 OR 加仓=50),30,0);
DRAWTEXT(加仓=50,35,'←加仓'),COLORBLUE;
做多:IF(ZDZK1>=ZDZK2,ZDZK1+2,ZDZK2),COLORYELLOW,LINETHICK5;
做空:IF(ZDZK2-ZDZK1,ZDZK2,ZDZK1),COLORGREEN,LINETHICK5;
DRAWBAND(做空,RGB(0,255,250),做多,RGB(255,50,50));VAR2:=MA(AMOUNT/(100*VOL),13);
VAR3:=MA(AMOUNT/(100*VOL),34);
VAR4:=DMA(CLOSE,VOL/CAPITAL);
VAR5:=WINNER(CLOSE)*100;
VAR6:=100*VOL/CAPITAL;
犀牛:(CLOSE-VAR2)/VAR2*100,LINETHICK,COLORYELLOW;
Y0:=ABS(WINNER(C)-WINNER(OPEN))*70;        
Y7C:=IF(VAR5>=90 AND VAR6<3,15.82,犀牛);   
{控制}
高:=MAX(MAX(犀牛,ABS(WINNER(C)-WINNER(O))*70),15.82);
低:=MIN(MAX(-犀牛,-ABS(WINNER(C)-WINNER(O))*70),-15.82);
{STICKLINE(C>REF(C,1),0,Y0,3,1),COLORRED;        
STICKLINE(C<=REF(C,1),0,Y0,3,0),COLORCYAN;}
STICKLINE(犀牛<=0,0,犀牛,2,0),COLOR005C00;
STICKLINE(犀牛>0,0,犀牛,2,0),COLORBLUE;
{STICKLINE(CROSS(C,VAR3),0,15.82,2,0),COLORRED;   
STICKLINE(CROSS(C,VAR4),0,15.82,2,0),COLORRED;
STICKLINE(CROSS(VAR2,VAR4),0,15.82,2,0),COLORRED;}
STICKLINE(Y7C>0,0,Y7C,1,0),COLORRED;             
STICKLINE(Y7C<=0,0,Y7C,1,0),COLORWHITE;DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);DDN:=C=HHV(C,180);
EE:=DEA< REF(DEA,1) AND REF(DEA< REF(DEA,1),1)=1;

CC:=C> REF(C,1) AND REF(C> REF(C,1),1)=1;
DRAWICON(CC AND EE,做空,5);
 

     

蚂蝗波段-通达信指标公式源码

VAR2:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR3:=(20*VAR2+19*REF(VAR2,1)+18*REF(VAR2,2)+17*REF(VAR2,3)+16*REF(VAR2,4)+15*REF(VAR2,5)+14*REF(VAR2,6)+13*REF(VAR2,7)+
12*REF(VAR2,8)+11*REF(VAR2,9)+10*REF(VAR2,10)+9*REF(VAR2,11)+8*REF(VAR2,12)+7*REF(VAR2,13)+6*REF(VAR2,14)+5*REF(VAR2,15)
+4*REF(VAR2,16)+3*REF(VAR2,17)+2*REF(VAR2,18)+REF(VAR2,20))/210;
VAR4:=MA(VAR3,13);
VAR5:=EMA(MA(CLOSE,3),34);
VAR6:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
VAR7:=MA(VAR6,5);
VAR8:=MA(VAR6,10);
STICKLINE(IF(VAR3<VAR5,VAR3<=1.015*VAR4,VAR3<=1.005*VAR4),VAR3,VAR4,10,1),COLOR006600 ;
STICKLINE(VAR3>1.005*VAR4,VAR3,VAR4,10,1),COLORFF00FF;
DRAWTEXT(FILTER(MA(VAR6,10)<VAR7,1),VAR8,'↑'),COLORRED;
DRAWTEXT(FILTER(MA(VAR6,10)>=VAR6,1),VAR8,'↓'),COLOR00FF00;
多空安全线: VAR5,COLORWHITE;
〖关注点〗: STICKLINE(COUNT(VAR3>1.005*VAR4 AND VAR3<=REF(VAR3,1),2)=2 OR
COUNT(IF(VAR3<VAR5,VAR3<=1.015*VAR4,VAR3<=1.005*VAR4) AND VAR3>=REF(VAR3,1),2)=2,VAR3,VAR4,10,0),COLORYELLOW;
DRAWTEXT(REF(CROSS(VAR3,VAR4),2) AND VAR3>1.005*VAR4,VAR4,'★买入点'),COLORWHITE;
DRAWTEXT(CROSS(VAR6,VAR7) AND VAR7<VAR8,VAR3*0.95,'▲'),COLORYELLOW;
{DRAWTEXT(CROSS(VAR7,VAR6) AND VAR7>VAR8,VAR3*1.05,'▼洗盘'),COLORWHITE;}
VAR9:=1/WINNER(CLOSE);
VARA:=MA(CLOSE,13);
VARB:=100-ABS((CLOSE-VARA)/VARA*100);
VARC:=LLV(LOW,75);
VARD:=HHV(HIGH,75);
VARE:=(VARD-VARC)/100;
VARF:=SMA((CLOSE-VARC)/VARE,20,1);
VAR10:=SMA((OPEN-VARC)/VARE,20,1);
VAR11:=3*VARF-2*SMA(VARF,15,1);
VAR12:=3*VAR10-2*SMA(VAR10,15,1);
VAR13:=100-VAR12;
VAR14:=100-VAR11;
VAR15:=MA(WINNER(CLOSE*0.95)*100,3);
VAR16:=100-IF(VAR9>5,IF(VAR9<100,VAR9,VARB-10),0);
VAR17:=VAR15>VARB;
VAR18:=REF(LOW,1)*0.9;
VAR19:=LOW*0.9;
VAR1A:=(VAR19*VOL+VAR18*(CAPITAL-VOL))/CAPITAL;
VAR1B:=EMA(VAR1A,30);
VAR1C:=CLOSE-REF(CLOSE,1);
VAR1D:=MAX(VAR1C,0);
VAR1E:=ABS(VAR1C);
VAR1F:=SMA(VAR1D,7,1)/SMA(VAR1E,7,1)*100;
VAR20:=SMA(VAR1D,13,1)/SMA(VAR1E,13,1)*100;
VAR21:=BARSCOUNT(CLOSE);
VAR22:=SMA(MAX(VAR1C,0),6,1)/SMA(ABS(VAR1C),6,1)*100;
VAR23:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR24:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR25:=SMA((SMA(VAR24,4,1)-50)*2,3,1);
VAR26:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR27:=SMA(VAR26,4,1);
VAR28:=SMA(VAR27,3,1);
VAR29:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR2A:=VAR22<=25 AND VAR23<-95 AND VAR29>20 AND VAR25<-30 AND VAR28<30 AND VAR1B-CLOSE>=-0.25 AND VAR1F<22 AND VAR20<28
AND VAR21>50;
DRAWTEXT(CROSS(VAR2A,0.5) AND COUNT(VAR2A=1,10)=1,VAR4,'♂发射资金'),COLORRED;
DRAWTEXT(CROSS(VAR17,0.5) AND COUNT(VAR17=1,10)=1,VAR3,'井喷'),COLORWHITE;
VAR326:=IF(CLOSE>REF(CLOSE, 1),88,0);
VAR327:=CLOSE/REF(CLOSE, 1)>1.050  AND HIGH/CLOSE<1.010 AND VAR326>0;
STICKLINE(VAR327>90,L*0.99,L*0.95,4,0),COLORYELLOW;

DRAWTEXT(VAR327>90,LOW*0.95,'追涨'),COLORYELLOW;

柳君主图-通达信指标公式源码

回归斜率线A:=EMA(SLOPE(C,4)*20+C,42);
经典RL:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
经典K:=SMA(经典RL,3,1); 经典D:=SMA(经典K,3,1); 经典J:=3*经典K-2*经典D;
MAHL1:=100*((EMA((H+L)/2,3)-LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20)))  /(LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20))));
MAHL2:=IF(EMA(C,2)>回归斜率线A AND MAHL1>0,EMA(C,3),LLV(EMA((H+L)/2,5),30));{A}
MAHL3:=IF(EMA(C,2)>回归斜率线A AND MAHL1>0,LLV(EMA((H+L)/2,5),30),EMA(C,5));{A}
回归斜率带:DRAWBAND(回归斜率线A,RGB(235,0,230),REF(回归斜率线A,2),RGB(0,104,154));
上线:=SMA(C,6.5,1);
一号支撑线:SMA(C,14.5,1);
上线1:=SMA(C,3,1);
一号支撑线1:=SMA(C,8,1);
上线2:=SMA(C,3.5,1);
DRAWTEXT(CROSS(一号支撑线1,上线1),H*1.08,'洗盘'),COLOR00FF00;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,25))/4;
UPR:=BBI+3*STD(BBI,13),LINETHICK2;
DWN:=BBI-3*STD(BBI,13);
安全:=MA(CLOSE,55),LINETHICK2;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT( CROSS(82,RSI) AND CLOSE<上线1 , HIGH*1.04,'减仓') ,COLORFF9966,LINETHICK2;
A7:=(2*C+H+L)/4;
操作:MA(A7,5),COLORBLUE,LINETHICK2;
操作1:=MA(A7,5)*1.03,LINETHICK2;
操作2:=MA(A7,5)*0.97,LINETHICK2;
DRAWTEXT( CROSS(上线1,上线) AND 上线1>操作,LOW *0.92,'买进' ),COLORYELLOW;
VAR1:LLV(A7,21);
VAR2:HHV(A7,30);
DRAWTEXT( CROSS(上线1,操作) AND 上线1<一号支撑线 AND 上线1<一号支撑线1 AND 上线1<上线 AND CLOSE>VAR1,LOW *0.98,'见底' ),COLORYELLOW;
YCX:=操作>=REF(操作,1);
H1:=MAX(MAX(上线,一号支撑线1),一号支撑线);
L1:=MIN(MIN(上线,一号支撑线1),一号支撑线);
DRAWTEXT(CROSS(上线1,一号支撑线1) AND 上线1>操作 ,LOW *0.98,'全仓' ),COLORYELLOW;
SK:=EMA((A7-VAR1)/(VAR2-VAR1)*100,7);
SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);
M1:=1000*操作/一号支撑线<=1015 AND 1000*操作/一号支撑线>=975;
M2:=1000*一号支撑线1/一号支撑线<=1020 AND 一号支撑线1/一号支撑线>=980;
M3:=1000*上线/一号支撑线<=1015 AND 上线/一号支撑线>=985;
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),13)/13>6/10 AND
COUNT(SK>SD,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE>=OPEN,4) AND
REF(CLOSE>OPEN,3) AND REF(CLOSE>OPEN,2) AND REF(OPEN>CLOSE,1) AND
OPEN>REF(CLOSE,1),1,0),LOW*0.94,'买进') ,COLORYELLOW;
D:=MA(CLOSE,89)-MA(CLOSE,10)/3;
DRAWTEXT(IF(CLOSE<D AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08
AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW*0.88,'抄底'),COLORBROWN;
RSV:=(CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100;
K:=SMA(RSV,3,1);
D1:=SMA(K,3,1);
J:=3*K-2*D1;
VAR3:=(2*CLOSE+HIGH+LOW)/3;{可将3该为4,信号少点}
VAR4:=EMA(EMA(EMA(VAR3,4),4),4);{可将3该为4,信号少点}
E:=(VAR4-REF(VAR4,1))/REF(VAR4,1)*100;
F:=MA(E,3)+0.03;
G:=MA(E,1);
DRAWICON(CROSS(F,G) AND J>65,HIGH*1.02,15),COLORGREEN;
DRAWICON(CROSS(G,F),LOW *0.9,9),COLORYELLOW;
DRAWTEXT(CLOSE>OPEN AND H1<C AND O<L1 AND YCX AND CROSS(上线1,操作) AND LOW>VAR1 AND 上线1>一号支撑线 AND J<90,LOW *0.9,'主升' ),COLORRED;
DRAWTEXT( CROSS(上线1,操作) AND M1 AND M2 AND M3,LOW *0.94,'买进' ),COLORYELLOW;
DRAWTEXT(CLOSE>OPEN AND 上线>一号支撑线1 AND 一号支撑线1>一号支撑线 AND CLOSE>MA(CLOSE,一号支撑线) AND 操作>=REF(CLOSE,操作) AND CROSS(上线1,操作) AND LOW>VAR1 AND J<90,LOW *0.9,'主升' ),COLORRED;
DRAWTEXT(CLOSE>OPEN AND 操作>上线 AND 上线>一号支撑线1 AND 一号支撑线1>一号支撑线 AND CROSS(上线1,操作) AND LOW>VAR1 AND J<90,LOW *0.86,'回踩买进' ),COLORRED;
DRAWTEXT(CLOSE>OPEN AND CROSS(上线,一号支撑线) AND LOW>VAR1 AND J<90,LOW *0.86,'回踩买进' ),COLORRED;
STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,0 ),COLORRED;
STICKLINE(C<O AND C>REF(C,1),C,O,3,0),COLORFFCC00;
STICKLINE(CLOSE> REF(CLOSE,1) AND C>O ,OPEN,CLOSE,3,0 ),COLOR000055;{红K};
STICKLINE(CLOSE> REF(CLOSE,1) AND C>O  ,OPEN,CLOSE,2.7,0 ),COLOR000077;{红K};
STICKLINE(CLOSE> REF(CLOSE,1) AND C>O  ,OPEN,CLOSE,2.1,0 ),COLOR000099;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;
STICKLINE(CLOSE= REF(CLOSE,1) ,H,L,3,1 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,0 ),COLORWHITE;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR555555;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;
STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(C<REF(C,1) AND C>O,C,O,3,0),COLORFFCC00;
STICKLINE(C<REF(C,1) AND C<O ,OPEN,CLOSE,3,0 ),COLOR990000;
STICKLINE(C<REF(C,1) AND C<O ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;
STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,3.2,0),COLORBB00FF;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,2.7,0),COLORFF33FF;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,2.1,0), COLORFF66FF;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,1.5,0),COLORFF99FF;

STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,0.9,0),COLORFFBBFF;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,0.3,0),COLORFFDDFF;

来福星-通达信指标公式源码

来势线: EMA(CLOSE,7)-EMA(CLOSE,21),COLORYELLOW;
福星: EMA(来势线,7), COLORSTICK,COLORRED;
VAR1:=CLOSE/REF(LLV(LOW,35),5)< 1;
决策: IF(VAR1,0.5,0), STICK,COLORBLUE;
必买: IF(TROUGHBARS(3,15,1)=0 AND HIGH>LOW+0.01,1,-1),COLORYELLOW ,LINETHICK1 ;
必卖: IF(PEAKBARS(3,15,1)=1,1,2),COLORWHITE,LINETHICK1;
趋势线: (EMA(WINNER(CLOSE),7)-EMA(WINNER(CLOSE),35))*5,COLORRED;
逃顶线: EMA(CLOSE/REF(HHV(CLOSE,7),50),1),COLOR007000 ,LINETHICK1 ;
AA:0,COLORBROWN;

DRAWICON(CROSS(趋势线,AA),AA,1);
DRAWICON(CROSS(逃顶线,趋势线),逃顶线,2);

股海扬帆-通达信指标公式源码

BIAS20:=(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100;
起航天数:BARSLAST(BARSLAST(BIAS20>0 AND REF(BIAS20,1)>0)>0),STICK,COLORRED,LINETHICK4;
休整天数:BARSLAST(BARSLAST(BIAS20<0 AND REF(BIAS20,1)<0)>0),STICK,COLOR00FFFF,LINETHICK4;
DRAWTEXT(起航天数=1,-5,'起'),COLORRED;
DRAWTEXT(起航天数=1,-10,'航'),COLORRED;
DRAWTEXT(休整天数=1,-5,'休'),COLORYELLOW;
DRAWTEXT(休整天数=1,-10,'整'),COLORYELLOW;
-20,COLOR000000;
VAR2W:=100-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
MW:= EMA(VAR2W,3);
VAR3W:=EMA(VAR2W,7);
M1:= EMA(VAR3W,5);
MB1:=CROSS(MW,M1) AND M1<20;
抄底介入:IF((MB1),20,0),LINETHICK2,COLORFF00FF;
DRAWTEXT(抄底介入 ,30,'抄底 '),COLORRED;
VAR06:=(2*CLOSE+HIGH+LOW)/4;
VAR08:=LLV(LOW,34);
VARB1:=HHV(HIGH,34);
BB:=EMA((VAR06-VAR08)/(VARB1-VAR08)*100,9);

VARC1:=EMA(0.667*REF(BB,1)+0.333*BB,2);
DRAWICON(FILTER(BB<REF(BB,1)AND BB>55 AND BB>REF(BB,3)AND C>MA(C,15),7),50,2);

神仙脚-通达信指标公式源码

金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友

VAR2:=TROUGHBARS(3,15,1)<10;
VAR3:=PEAKBARS(3,15,1)<10;
VAR4:=IF(VAR2=1,50,0);
VAR5:=IF(VAR3=1,50,0);
底部:=IF(VAR4=50,10,0);
多头能量:0,COLORWHITE,LINETHICK2;

买入:IF(底部=10 AND REF(底部,1)=10 AND REF(底部,2)=0,50,0),COLOR0000CC,LINETHICK2;
买入延迟线:底部,LINETHICK1 ,COLOR00CCFF;

  跟庄MA

STICKLINE(C>0,-100,200,8,0),COLOR444444;
N:=1.5;
M:=3;
P:=64;
DIFF:=EMA((EMA(CLOSE,N*12)-EMA(CLOSE,N*26))/EMA(CLOSE,N*26)*1000,M);
DEA:=EMA(DIFF,N*9),COLOR000088;
MACD:=2*(DIFF-DEA);
MACDX:=MACD;
MACDO:=EMA(MACD,5),COLORFF77FF;
DIFFO:=EMA(DEA,P)*1.8;
B:=MACD-REF(MACD,1);
(MACD>0 AND B>0,0,MACD,0,1),COLOR0000CD;
STICKLINE(MACD>0 AND B<0,0,MACD,0,0),COLOR0000CD;
STICKLINE(MACD<0 AND B>0,0,MACD,0,1),COLORCYAN;
STICKLINE(MACD<0 AND B<0,0,MACD,0,0),COLORCYAN;
STICKLINE(DIFF>DEA,DIFF,DEA,4,0),COLOR0089FF;
STICKLINE(DIFF<DEA,DIFF,DEA,4,0),COLORBLUE;
发现机构入场:IF(DIFF>=REF(DIFF,1) AND DEA<REF(DEA,1),DIFF,DRAWNULL),COLOR00C500,LINETHICK4;
短线出局:IF(DIFF<REF(DIFF,1) AND DEA>REF(DEA,1),DIFF,DRAWNULL),COLORYELLOW,LINETHICK4;
IF(DIFF>=REF(DIFF,1) AND DEA>REF(DEA,1),DIFF,DRAWNULL),COLORGRAY;
IF(DIFF<REF(DIFF,1) AND DEA<REF(DEA,1),DIFF,DRAWNULL),COLORBLUE;
IF(DIFFO>=REF(DIFFO,1),DIFFO,DRAWNULL),COLORYELLOW;
IF(DIFFO=REF(DIFFO,1),DIFFO,DRAWNULL),COLORYELLOW;
IF(DIFFO<REF(DIFFO,1),DIFFO,DRAWNULL),COLORMAGENTA;

DRAWTEXT(C=C AND CURRBARSCOUNT=150,180,'操作:蓝转绿试买;见橙加仓;维持橙持股'),COLOR008987;
DRAWTEXT(C=C AND CURRBARSCOUNT=150,150,'橙转黄减仓;蓝色空仓'),COLOR008987;
主力资金

VAR2:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
VAR3:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
VAR4:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
VAR5:=(((VAR2 + (2 * VAR3)) + (3 * VAR4)) / 6);
VAR6:=MA(VAR5,3);
开始控盘:=STICKLINE((VAR6 <= (0 - 10)),0,(0 - 20),3.5,0),COLOR00AAFF;
STICKLINE((VAR6 <= (0 - 10)),0,(0 - 20),3.5,0),COLOR0044FF;
STICKLINE((VAR6 <= (0 - 10)),0,(0 - 20),2.5,0),COLOR0088FF;
STICKLINE((VAR6 <= (0 - 10)),0,(0 - 20),3,0),COLOR00AAFF;
VAR1:=EMA(EMA(CLOSE,3),1);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
STICKLINE(控盘<0,控盘,0,3.5,0),COLORFFAA00;
STICKLINE(控盘<0,控盘,0,3.5.2,0),COLORFF4400;
STICKLINE(控盘<0,控盘,0,2.5,0),COLORFF8800;
STICKLINE(控盘<0,控盘,0,0,0),COLORFFAA00;
主力出货:0,COLORFFAA00;
STICKLINE(控盘>REF(控盘,3) AND 控盘>0,控盘,0,3.5,0),COLOR000088;
STICKLINE(控盘>REF(控盘,3) AND 控盘>0,控盘,0,2.5,0),COLOR0000AA;
STICKLINE(控盘>REF(控盘,3) AND 控盘>0,控盘,0,1.5,0),COLOR0000CC;
STICKLINE(控盘>REF(控盘,3) AND 控盘>0,控盘,0,1,0),COLOR0000EE;
主力吸货:0,COLOR0000FF;
STICKLINE(控盘<REF(控盘,3) AND 控盘>0,控盘,0,3.5,0),COLOR008800;
STICKLINE(控盘<REF(控盘,3) AND 控盘>0,控盘,0,2.5,0),COLOR00AA00;
STICKLINE(控盘<REF(控盘,3) AND 控盘>0,控盘,0,1.5,0),COLOR00CC00;
STICKLINE(控盘<REF(控盘,3) AND 控盘>0,控盘,0,1,0),COLOR00EE00;
STICKLINE(DDX<0,0,DDX,3.5,0),COLOR008800;
STICKLINE(DDX<0,0,DDX,2.5,0),COLOR00AA00;
STICKLINE(DDX<0,0,DDX,1.5,0),COLOR00CC00;
STICKLINE(DDX<0,0,DDX,1,0),COLOR00EE00;
对倒出货洗盘:0,COLOR00FF00;
黄色底部吸货:0,COLORYELLOW;

DRAWTEXT(CROSS(控盘,0),0-3,'买。追'),COLORFF00FF;
DRAWTEXT(CROSS(0,控盘),0-0,'卖'),COLORGREEN;
DATA:=5;
{多头买入} DRAWICON(ZIG(3,DATA)>REF(ZIG(3,DATA),1)
AND REF(ZIG(3,DATA),1)<=REF(ZIG(3,DATA),2)
AND REF(ZIG(3,DATA),2)<=REF(ZIG(3,DATA),3),L*0.98,1);

{多头卖出} DRAWICON(ZIG(3,DATA)<REF(ZIG(3,DATA),1)
AND REF(ZIG(3,DATA),1)>=REF(ZIG(3,DATA),2)
AND REF(ZIG(3,DATA),2)>=REF(ZIG(3,DATA),3),H*1.02,2);
太阳拉升

Y1:=LLV(L,17);
Y2:=SMA(ABS(L-REF(L,1)),17,1);
Y3:=SMA(MAX(L-REF(L,1),0),17,2);
Q:=-(EMA(IF(L<=Y1,Y2/Y3,-3),1));
STICKLINE(CROSS(Q,0),15,0,4,0), , COLORYELLOW;
强拉升: IF(CROSS(Q,0),1,0),COLORYELLOW;
Q1:= (CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100, , COLOR00FF00,LINETHICK2;
STICKLINE(CROSS(Q1,-24),20,0,4,0), , COLORMAGENTA;
加强拉升: IF(CROSS(Q1,-24),1,0),COLORMAGENTA;
VAR2:=EXPMA(EXPMA(EXPMA((2*CLOSE+HIGH+LOW)/4,4),4),4);
天:=( MA((VAR2-REF(VAR2,1))/REF(VAR2,1)*100,2));
地:=( MA((VAR2-REF(VAR2,1))/REF(VAR2,1)*100,1));
STICKLINE(地>天 AND 地<0,10,0,1,0),COLORRED;
开始拉升:STICKLINE(地>天 AND 地<0,10,0,1,0)=1,COLORRED;

 

多头分时

金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友

MA30:=EMA(CLOSE,30);
{强弱:EMA(CLOSE,900);
STICKLINE((MA30>强弱),MA30,强弱,1,0),COLOR0000FF;
STICKLINE((MA30<强弱),MA30,强弱,1,0),COLOR00FF00;}
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:L1+P1*7/8,COLOR00DD00;
支撑:L1+P1*0.5/8,COLOR00DD00;
现价:CLOSE,COLORWHITE,LINETHICK1;
STICKLINE(CROSS(支撑,现价),支撑,阻力,1,0),COLORYELLOW;
DRAWTEXT(LONGCROSS(支撑,现价,2),支撑*1.001,'买'),COLORYELLOW;{吸}
DRAWTEXT(LONGCROSS(现价,阻力,2),现价,'★卖'),COLORRED;{抛};
日时转换:=IF(PERIOD=5,120,240);
QZS:=(EMA(CLOSE,10)+EMA(CLOSE,32))/2;
VAR1:=(EMA(CLOSE,30)+EMA(CLOSE,72))/2;
VAR2:=(EMA(VOL,10)+EMA(VOL,32))/2;
VAR3:=(VAR1+VAR2)/2;
VAR4:=EMA(VAR3,30);
VAR5:=EMA(VAR3,60);
VAR6:=EVERY(VAR1>REF(VAR1,1),5) AND EVERY(VAR4>REF(VAR4,1),5);
DRAWBAND(VAR1,RGB(150,30,30),EMA(VAR1,60),RGB(0,110,30));
牵引线:VAR1,COLORYELLOW;
强弱线:EMA(VAR1,日时转换),POINTDOT,COLORWHITE;
趋势关注:IF(CROSS(VAR1,EMA(VAR1,60)) AND VAR6,1,0),NODRAW,COLORRED;
量价关注:IF(CROSS(VAR3,VAR5) AND VAR6,1,0),NODRAW,COLORWHITE;
冲击量:IF(VAR3>VAR5 AND VAR6,1,0),NODRAW,COLORYELLOW;
强势区:IF(VAR1>强弱线,1,DRAWNULL),NODRAW,COLORRED;
止损区:IF(VAR1<强弱线,1,DRAWNULL),NODRAW,COLORGREEN;
STICKLINE(QZS>VAR1,QZS,VAR1,1,0),COLORFF00FF;
STICKLINE(冲击量=1,QZS,VAR1,1,0),COLORYELLOW;
DRAWICON(趋势关注=1,EMA(VAR1,60),13);
DRAWTEXT(量价关注=1,EMA(VAR1,60),'★'),COLORWHITE;
   通达信RSI实战源码公式

金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友
LC:=REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100,COLORWHITE;
AA:=REF(RSI1,HIGHN)=HHV(RSI1,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND RSI1=HHV(RSI1,HIGHN+1);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
AA1:=REF(RSI1,HIGHN)=LLV(RSI1,2*HIGHN+1);
QY1:=BACKSET(AA1,HIGHN+1);
CC1:=FILTER(QY1,HIGHN) AND RSI1=LLV(RSI1,HIGHN+1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
A1:=REF(RSI1,P)=HHV(RSI1,2*P+1);
B1:=FILTER(A1,P);
C1:=BACKSET(B1,P+1);
D1:=FILTER(C1,P);
A2:=REF(RSI1,P)=LLV(RSI1,2*P+1);
B2:=FILTER(A2,P);
C2:=BACKSET(B2,P+1);
D2:=FILTER(C2,P);
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);
S11:=R11>REF(R11,1);
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
U11:=T11>REF(T11,1);
MID:=MA(RSI1,20);
UPPER:=MID + 2*STD(RSI1,20);
LOWER:=MID - 2*STD(RSI1,20);
高:=REF(HHV(RSI1,360),1);
低:=REF(LLV(RSI1,240),1);
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,6);
前高:REF(RSI1,BARSLAST(D1)),COLORFF00FF,NODRAW;
前低:REF(RSI1,BARSLAST(D2)),COLOR00FF00,NODRAW;
相对能量:(RSI1-前低)/(前高-前低)*100,COLORYELLOW,NODRAW;

上轨:UPPER,COLOR993300;
下轨:LOWER,COLOR993300;
DRAWICON(CC,RSI1*1.03,2);
DRAWICON(CC1,RSI1*0.97,1); 
高压:DRAWLINE(CURRBARSCOUNT=GDCS2,RSI1,CURRBARSCOUNT=GDCS1,RSI1,1) COLORBLUE,POINTDOT,LINETHICK4;
低支:DRAWLINE(CURRBARSCOUNT=DDCS2,RSI1,CURRBARSCOUNT=DDCS1,RSI1,1) COLORRED,POINTDOT,LINETHICK4;
阻力:DRAWLINE(D1,RSI1,S11,RSI1,1),COLORYELLOW;
支撑:DRAWLINE(D2,RSI1,U11,RSI1,1),COLOR00FF00;
DRAWTEXT(CROSS(RSI1,LOWER),LOWER,'抄'),COLOR00FF00;
DRAWTEXT(CROSS(LOWER,RSI1),LOWER,'▼'),COLOR00FF00;
DRAWTEXT(CROSS(RSI1,高),MID,'年高'),COLORYELLOW;
DRAWTEXT(CROSS(低,RSI1),MID,'年低'),COLORYELLOW;
DRAWTEXT(CROSS(UPPER,RSI1),UPPER,'逃'),COLORYELLOW;
DRAWTEXT(CROSS(RSI1,UPPER),UPPER,'▲'),COLORYELLOW;
VM:MA(RSI1,N1),COLORFF00FF,NODRAW;
STICKLINE(CROSS(BIAS,乖离)  AND 乖离<-9,6,0,2,0),COLORRED;
DRAWTEXT(ISLASTBAR AND RSI1>REF(RSI1,1),VM,' ▲'),COLORDD00FF;
DRAWTEXT(ISLASTBAR AND RSI1<REF(RSI1,1),VM,' ▼'),COLORCCEE00;
DRAWTEXT(CURRBARSCOUNT=60,10,' ☆ 实战☆'),COLORGREEN;

 无敌精准买卖(副图、源码、贴图)

 VAR1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR2:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR3:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR5:=(VAR2+2*VAR3+3*VAR4)/6;
VAR6:=MA(VAR5,3);
MACD: VAR6*5,COLORSTICK ,LINETHICK2 ;
提醒: STICKLINE(VAR6<=-6,0,-25,5,0), COLOR88B7EA ;
关注: STICKLINE(VAR6<=-8,5,25,7,0)  ;
出击: STICKLINE(VAR6<=-10,80,100,5,0),  COLORYELLOW;
警戒雷达: IF(VAR6<-6,20,0),LINETHICK3 , COLORFF0000;
引导雷达: STICKLINE(VAR6<=-10,65,35,4,0);
制导雷达: STICKLINE(VAR6<=-10,40,0,4,0),  COLORRED;
发射: STICKLINE(VAR6<=-10,80,30,3,0), COLORGREEN;
导弹: STICKLINE(VAR6<=-10,80,60,3,0),   COLORWHITE;
K: SMA(VAR1,3,1),  COLORGREEN;
D: SMA(K,3,1),   COLORYELLOW;
J: 3*K-2*D,  COLORWHITE;
底: 20,LINETHICK1 , COLOR77AA1A;
入顶: 80,LINETHICK1 , COLOR9966FF;
大顶: 100,LINETHICK1 ,COLOR22A6E6;
    趋势买卖(原码)

金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友

一。趋势通道向上运行
二。黄色买进信号越靠近趋势通道底部就是粉色线越好
三。KDJ中J线拐头最好向上金叉。如果符合三个条件,必定赚钱。
n 1  100  20  m 1  100  32 p1 1  100  80  p2 1  100  100
公式如下:
VAR1:=(C+H+O+L)/4;
卖出:XMA(VAR1,N)*(1+P1/1000),COLORGREEN,LINETHICK2;
买入:XMA(VAR1,M)*(1-P2/1000),COLORMAGENTA,LINETHICK2;
幅度:100*(卖出-买入)/买入,NODRAW;
MA1:=MA(VAR1,3);
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,MAX(卖出,MAX(OPEN,CLOSE)),3,0),COLORGREEN;
STICKLINE(卖出>MIN(C,O) AND 卖出<MAX(C,O),卖出,MAX(OPEN,CLOSE),3,0),COLORGREEN;
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,HIGH,0,0),COLORGREEN;
STICKLINE(卖出<LOW,OPEN,CLOSE,3,0),COLORGREEN;
STICKLINE(卖出<LOW,HIGH,LOW,0,0),COLORGREEN;
STICKLINE(买入>LOW AND 买入<HIGH,买入,MIN(MIN(OPEN,CLOSE),买入),3,0),COLORMAGENTA;
STICKLINE(买入>MIN(C,O) AND 买入<MAX(C,O),买入,MIN(OPEN,CLOSE),3,0),COLORMAGENTA;
STICKLINE(买入>LOW AND 买入<HIGH,买入,LOW,0,0),COLORMAGENTA;
STICKLINE(买入>HIGH,OPEN,CLOSE,3,0),COLORMAGENTA;
STICKLINE(买入>HIGH,HIGH,LOW,0,0),COLORMAGENTA;
DRAWTEXT(CROSS(LOW,买入),LOW*0.95,'B'),COLORRED,LINETHICK2;
DRAWTEXT(CROSS(卖出,HIGH),HIGH*1.02,'S'),COLORGREEN;
赢富伴侣-- (副图、源码、 贴图)

金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友
VA1:=100-3*SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1);
VA2:=100-3*SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1);
VA3:=VA1<REF(VA2,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(VA3 AND COUNT(VA3,30)=1,15,'有大资金进关注'),LINETHICK1,COLORFF00FF;
A:=WINNER(CLOSE+CLOSE*15/100)*100;
B:=WINNER(CLOSE+CLOSE*0/100)*100;
CC:=A-B;
D:=(WINNER(CLOSE-CLOSE*0.1/100)-WINNER(CLOSE-CLOSE*15/100))*100;
E:=CC<3 AND D<0.5 AND OPEN!=LOW;
A1:=DYNAINFO(6);
A2:=IF(LOW>A1,0,IF(HIGH<A1,1,(A1-LOW+0.01)/(HIGH-LOW+0.01)));
A3:=VOL/WINNER(LOW);
A4:=REF(HHV(CLOSE,120),1);
A5:=REF(LLV(CLOSE,120),1);
A6:=100*(CLOSE-A5)/(A4-A5);
A7:=A2>0 OR A2=1;
A8:=A7 AND A3/REF(A3,3)>=3 AND A6<80;
A9:=REF(A8,1) OR REF(A8,2) OR REF(A8,3) OR REF(A8,4);
A10:=A8 AND A9;
A11:=IF(FILTER(A8,3),5,0);
A12:=IF(FILTER(A10,3) OR E,10,0);
资金进场日:IF(A11>0,8,DRAWNULL),COLOR00FFFF,LINETHICK3,STICK;
资金加仓日:IF(A12>0,15,DRAWNULL),COLORFF00FF,LINETHICK4,STICK;
DRAWTEXT(A11,8,'资金进场');
DRAWTEXT(A12,17,'资金加仓');
VAR1:=(CLOSE*2+HIGH+LOW)/4*10;
VAR2:=EMA(VAR1,13)-EMA(VAR1,34);
VAR3:=EMA(VAR2,5);
VAR4:=2*(VAR2-VAR3)*5.5;
主力:VAR4,COLORRED,LINETHICK2;
{0,COLORWHITE;}
VAR5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
VAR6:=EMA(3*VAR5-2*SMA(VAR5,18,1),5);
VAR7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;
VAR8:=(INDEXC*2+INDEXH+INDEXL)/4;
VAR9:=EMA(VAR8,13)-EMA(VAR8,34);
VARA:=EMA(VAR9,3);
VARB:=(VAR9-VARA)/2;
大盘资金:VARB,COLORGREEN,LINETHICK2;
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR10:=(HIGH+LOW+CLOSE)/3;
VAR11:=(VAR10-MA(VAR10,14))/(0.015*AVEDEV(VAR10,14));
VAR12:=(VAR10-MA(VAR10,70))/(0.015*AVEDEV(VAR10,70));
VAR13:=IF(VAR11>=150 AND VAR11<200 AND VAR12>=150 AND VAR12<200,10,0);
VAR14:=IF(VAR11<=-150 AND VAR11>-200 AND VAR12<=-150 AND VAR12>-200,-10,VAR13);
VAR15:=(CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*100;
VAR16:=100-ABS(VAR15);
VAR17:=IF(VAR16<90,VAR16,100);
VAR1A:=IF(VARE>0,VARE,0);
VAR1B:=IF(VAR12>=200 AND VAR11>=150,15,IF(VAR12<=-200 AND VAR11<=-150,-15,VAR14))+60;
VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR17<100;
DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,15,'大笔出货.缩量(低位)则洗.'),LINETHICK1,COLORFFCC66;
T1:(VA3 AND COUNT(VA3,30)=1)*28,COLORFFFFFF;
T:(COUNT(A8,30)>=3 AND COUNT(A10,30)>=3)*38,COLORBLUE;
笑脸看盘主图源码100%准确的主图指标和笑脸选股公式

金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友

金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友
流通盘:FINANCE( 7)/10000, NODRAW;
A1A:=EMA(CLOSE, 9);
A1B:=((A1A - EMA(CLOSE, 5)) < 0);
A1C:=((A1A - EMA(CLOSE, 5)) > 0);
A1D:=BARSLAST(A1B);
A1E:=BARSLAST(A1C);
A1F:=IF((A1E > 0),(CLOSE - REF(CLOSE, 1)) / REF(CLOSE, 1) *  100,0);
A20:=SUM(A1F,0);
A21:=IF((A1D > 0),(0 -  2),0);
A22:=IF((A1E > 0),SUM((CLOSE - REF(CLOSE, 1)) / REF(CLOSE, 1) *  100,A1E),0);
A23:=A22 / A1E;
A25:=EMA(EMA(EMA(CLOSE, 3), 3), 3);
多方:((A25 - REF(A25, 1)) + A25)COLOR0000FF,LINETHICK2;
K2:=BACKSET(多方<REF(多方,1),2);
IF(K2,多方,DRAWNULL),COLOR00A600,LINETHICK2;
空方:MA(多方, 15)COLORFF49FF;
K1:=BACKSET(空方<REF(空方,1),2);
IF(K1,空方,DRAWNULL),COLOR00A600,LINETHICK2;
IF(多方>REF(多方,1),多方,DRAWNULL),COLORFFFFCC,LINETHICK4,POINTDOT;
IF(空方>REF(空方,1),空方,DRAWNULL),COLOR00FFFF,LINETHICK4,POINTDOT;
STICKLINE((多方 > 空方),空方,多方, 0, 0)COLOR00FFFF;
STICKLINE((空方 > 多方),多方,空方, 0, 0)COLORFF0000;
DRAWTEXT(CROSS(空方,多方),多方 *  1.01,'↓卖')COLOR00FF00;
DRAWTEXT(CROSS(多方,空方),空方 *  0.99,'↑买')COLOR0000FF;
DRAWICON(((REF(A21, 1) = (0 -  2)) AND (A21 = 0)),LOW, 5);
DRAWICON(((REF(A1E, 1) > 0) AND (A1E = 0)),HIGH, 6);


100%准确的主图指标和选股指标

发笑脸选股   
VAR3:=MA(100*(C-LLV(C,34))/(HHV(H,34)-LLV(L,34)),5)-10;
VAR4:=SMA(100*(C-LLV(L,55))/(HHV(H,55)-LLV(L,55)),13,1)-10;
VAR5:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*50;
CROSS(VAR3,VAR4)AND VAR4<20 AND LONGCROSS(VAR5,0,10);

个股买卖(个股强、个股弱、差值、大盘)-指标公式源码
金泉—多头    通达信指标公式源码 - 以博会友 - 以博会友
大盘MS:=EMA(100*(INDEXC-LLV(INDEXL,5))/(HHV(INDEXH,5)-LLV(INDEXL,5)),5);
个股强:=EMA(100*(C-LLV(LOW,5))/(HHV(H,5)-LLV(LOW,5)),5);
K1:=BACKSET(个股强<REF(个股强,1),2);
个股弱:=IF(K1,个股强,DRAWNULL);
差值:=个股强-大盘MS,{POINTDOT};
0,POINTDOT;
STICKLINE( 个股强>0,0 ,个股强*1.0,4 ,0 )COLOR0000FF;
STICKLINE( 个股强>0,0 ,个股强*0.8,4 ,0 )COLOR0066FF;
STICKLINE( 个股强>0,0 ,个股强*0.6,4 ,0 )COLOR0099FF;
STICKLINE( 个股强>0,0 ,个股强*0.4,4 ,0 )COLOR00CCFF;
STICKLINE( 个股强>0,0 ,个股强*0.2,4 ,0 )COLOR00FFFF;
STICKLINE( 个股弱=个股弱,0 ,个股弱*1.0,4 ,0 )COLOR00FF00;
STICKLINE( 个股弱=个股弱,0 ,个股弱*0.8,4 ,0 )COLOR00CC33;
STICKLINE( 个股弱=个股弱,0 ,个股弱*0.6,4 ,0 )COLOR009933;
STICKLINE( 个股弱=个股弱,0 ,个股弱*0.4,4 ,0 )COLOR007733;
STICKLINE( 个股弱=个股弱,0 ,个股弱*0.2,4 ,0 )COLOR005500;
大盘MSD:EMA(100*(INDEXC-LLV(INDEXL,5))/(HHV(INDEXH,5)-LLV(INDEXL,5)),5),COLORWHITE,LINETHICK1;
K2:=BACKSET(个股强>REF(个股强,1),2);
个股强买:IF(K2,个股强,DRAWNULL),COLORMAGENTA,LINETHICK3;
K3:=BACKSET(个股强<REF(个股强,1),2);

个股弱卖:IF(K3,个股强,DRAWNULL),COLORBLUE,LINETHICK3;
DRAWTEXT(CROSS(大盘MS,20),20,'大盘反弹'),COLORRED,LINETHICK3;







 

  评论这张
 
阅读(7)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017